GNU/Linux packages

There are binary builds of GNU Backgammon for GNU/Linux available, both as RPM packages for SuSE and RedHat. Debian GNU/Linux packages will follow shortly.

All packages are signed by Achim Müller. You can find the PGP public key either here or at any keyserver.

The packages are built with 3d-support. They are also optimized for i686 computers with sse support:

Gnubg rpms for OpenSuSE-10.1
Gnubg rpms for RedHat Advanced Server 4



Install instructions

There is no warranty on these packages. If your system crashes, your monitor explodes or your last dissertation goes to nirvana ... don't blame me.

I divided the packages into "gnubg" (needs OpenGL!), "gnubg-databases" and "gnubg-sounds". If you already have the databases and sounds you only need to update the main package.

The RedHat packages should also work on Redhat-9, Fedora Core 4 and Mandriva 2006.

When you have problems while installing, find errors or have suggestions, don't hesitate to drop me a line.

If you want to compile from source-rpm, do a

#: rpmbuild --rebuild [package]

The packages are all signed with my key. To verify them, do a

#: rpm --import [public key]
#: rpm --checksig [package]

If you don't trust my key at my homepage, you may also get my key from any keyserver. If you don't trust me at all, I can't help you.

Ciao

Achim
posted at 22:56:08 on 10/08/04 by webadmin - Category: Download and install

Comments

John Hedge wrote:

Hi,

I tried to install the deb file with the following result.

dpkg -i gnubg_0.14-1_i386.deb
Selecting previously deselected package gnubg.
(Reading database ... 86288 files and directories currently installed.)
Unpacking gnubg (from gnubg_0.14-1_i386.deb) ...
dpkg-deb (subprocess): short read in buffer_copy (failed to write to pipe in copy)
dpkg-deb: subprocess paste returned error exit status 2
dpkg: error processing gnubg_0.14-1_i386.deb (--install):
short read in buffer_copy (backend dpkg-deb during `./usr/share/gnubg/gnubg_os0.bd')
Errors were encountered while processing:
gnubg_0.14-1_i386.deb

Any ideas?

John
10/28/04 12:39:27

bill wrote:

Problem with synaptic (front end of apt-get) because I have not install 3d nvidia drivers. Apt checks dependencies and finds that the db requires gnu.rpm and this dependency is not met by gnu-no-3d. This cause synaptic to try and fix the problem anytime used and it will not allow 'broken' packages
11/04/04 23:02:58

Enrico wrote:

I tried to install on suse 9.2 .
It complains that it need libreadline.so.4.
In the default suse 9.2 installation there is a libreadline.so.5 .
What shall I do?

Enrico
11/25/04 17:29:06

John wrote:

All rpms and debs. Hum, I'd like to be able to install it to Gentoo linux.

I don't know if anyones produced an "e-build" or whether the source is available so it could be installed that way?

What's the best suggestion ?
11/30/04 21:22:35

john wrote:

Ok, sorry about that. I'm so used to have to dig around for stuff, when it's under my nose, I can't see it.

For anyone who uses gentoo, you know what you have to do!

"#emerge gnubg"

Keep up the good work gnubg!
11/30/04 21:45:02

johnhenry wrote:

The Linux version (as in Knoppix 4.0 DVD) seems to have omitted the Finish Move item from the menu. How to hand over to the computer? Even CTL-F fails.
05/22/06 15:56:09

Add Comments

This item is closed, it's not possible to add new comments to it or to vote on it
I have no doubt that GNU Backgammon 2-ply would show a positive result if given enough time vs. any human player in match play.
--Neil Kazaross

Screenshots

ScreenshotScreenshotScreenshotScreenshotScreenshot
Valid XHTML 1.0! Valid CSS!
Powered by Nucleus CMS